CRAN Package Check Results for Package AIPW

Last updated on 2024-07-23 20:49:02 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.6.3.2 7.24 72.92 80.16 OK
r-devel-linux-x86_64-debian-gcc 0.6.3.2 4.14 54.24 58.38 NOTE
r-devel-linux-x86_64-fedora-clang 0.6.3.2 106.17 NOTE
r-devel-linux-x86_64-fedora-gcc 0.6.3.2 114.00 NOTE
r-devel-windows-x86_64 0.6.3.2 7.00 73.00 80.00 NOTE
r-patched-linux-x86_64 0.6.3.2 12.02 71.89 83.91 OK
r-release-linux-x86_64 0.6.3.2 6.66 73.06 79.72 OK
r-release-macos-arm64 0.6.3.2 36.00 OK
r-release-macos-x86_64 0.6.3.2 60.00 OK
r-release-windows-x86_64 0.6.3.2 7.00 75.00 82.00 OK
r-oldrel-macos-arm64 0.6.3.2 37.00 OK
r-oldrel-macos-x86_64 0.6.3.2 58.00 OK
r-oldrel-windows-x86_64 0.6.3.2 9.00 85.00 94.00 OK

Check Details

Version: 0.6.3.2
Check: Rd cross-references
Result: NOTE Found the following Rd file(s) with Rd \link{} targets missing package anchors: AIPW.Rd: SuperLearner AIPW_base.Rd: R6Class Please provide package anchors for all Rd \link{} targets not in the package itself and the base packages. Flavors: r-devel-linux-x86_64-debian-gcc, r-devel-windows-x86_64

Version: 0.6.3.2
Check: dependencies in R code
Result: NOTE Namespaces in Imports field not imported from: ‘Rsolnp’ ‘SuperLearner’ ‘future.apply’ ‘ggplot2’ ‘progressr’ ‘stats’ ‘utils’ All declared Imports should be used. Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc